Problem compiling an Altus iOS program

0 votes
asked Jun 20, 2016 by ba3user (4,000 points)

Thank you for the new build. Unfortunately, I am running into an exception in detectHitOnMap:atScreenPoint:withVertexHitBuffer:withLineHitBuffer:

EXC_BAD_ACCESS (code=1, address=0x4)

I’ve tried re-adding the framework several times with the same result. When I revert back to the previous release, there is no exception (although the line segment hit-testing indexing is still incorrect).

1 Answer

0 votes
answered Jun 20, 2016 by ba3user (4,000 points)

We have seen this behavior before. Xcode's LLVM compiler will often cache intermediate build artifacts in several areas. One area that is problematic is /var/folders, which is supposed to be cleaned up upon reboots of the OS.

Please try the following:

1. Restart OS X and Xcode
2. Delete the old framework files and replace them with the new framework
3. Open your Xcode project
4. Two step cleaning process:
a. Click Product / Clean
b. IMPORTANT: Hold holding down the Alt key, click Product / Clean Build Folder...

The "Clean Build Folder..." menu option only appears if you are holding down the Alt key.

5. Try building your app again.

If you still have problems, try the following:
1. In Xcode, Open Window / Projects
2. Manually delete the derived data folders